Oracle Commerce Support Statement on Java 1.7 End-of-Life for Oracle Commerce Applications (Doc ID 1991047.1)

Last updated on JANUARY 05, 2017

Applies to:

Oracle Commerce Platform - Version 11.0 to 11.2 [Release 11]
Information in this document applies to any platform.

Goal

Oracle Commerce 11.x requires Java JDK 1.7, but Java 7 reached end-of-life status in April 2015. What is the support status of these versions of Oracle Commerce applications?

For Java 1.6 EOL see Note 1526401.1 - Oracle ATG Support Statement on Java 1.6 End-of-Life for ATG Applications

Note: ATG 10.2.0.x is supported on 1.6 but for WebLogic Server only could be deployed on 1.7. 11.0 is the first release that requires 1.7.

Solution

Sign In with your My Oracle Support account

Don't have a My Oracle Support account? Click to get started

My Oracle Support provides customers with access to over a
Million Knowledge Articles and hundreds of Community platforms