My Oracle Support Banner

Latest Generally Available Patch Set for Oracle Communications Services Gatekeeper 6.0 (Doc ID 1993751.1)

Last updated on NOVEMBER 30, 2019

Applies to:

Oracle Communications Services Gatekeeper - Version 6.0.0 to 6.0.0 [Release 6.0]
Information in this document applies to any platform.

Details

Patch Set 3 <Patch 25296732> has been released for Oracle Communications Services Gatekeeper 6.0. 

Please refer to the Release Notes and Read Me Documents in the patch zip for complete details.

It is important to be up-to-date with patches, and besides updating the OCSG software it's recommended to also patch the following components used by OCSG:
* Java SE7 (<Document 1439822.1>)
* Weblogic server 12.1.3 (<Document 1470197.1>)
* Coherence 12.1.3 (<Document 1957618.1>)
Unless stated otherwise in JDK, WLS & Coherence patches we recommend to apply patches in order: JDK, WLS, Coherence, OCSG.

OCSG Patch Set 3 was tested based on the following patches:

Product Patch ID Version Description
JDK <Patch 25091448> 1.7.0.121 b32  JDK 7 Update 121 b32
WebLogic <Patch 29633448> 12.1.3.0.190716 12.1.3 PSU 190716
Coherence <Patch 27201130> 12.1.3.0.6 Coherence 12.1.3.0.6

 

See Release Notes for Bugs fixed in PS3.

 

 

Actions

Please download <Patch 25296732> and deploy after having reviewed the Release Notes and Read Me Documents.

The JDK, WebLogic and Coherence patch recommended in this article overwrites the versions in the Read Me file inside the patch zip.

Note:

You might see the following information while installing Patch Set 3, please input "y", to allow all conflicting patches being rolled back and Patch Set 3 being installed:

Patch(es) [ 22545893 22695450 22731094 23128403 ] are subset patch(es) of the Patch currently being installed [ 25296732 ].
Patch(es) [ 22892576 ] conflict with the Patch currently being installed [ 25296732 ].

To resolve patch conflicts, please contact Oracle Support Services.
If you continue, all conflicting patch(es) will be rolled back and the new Patch [ 25296732 ] will be installed.

Do you want to proceed? [y|n]

 

Note, if you are upgrading from OCSG 5.1 to 6.0 PS3 you may need <Patch 20919488> to fix the issue with migration tool. See <Document 2002071.1>.

 

 Note, before restarting the domain, please clean up $Domain-Home/servers/<servername>/tmp on all servers, and $Domain-Home/servers/<servername>/stage on all managed servers.

 

Note if you have Node Manager configured, after PS3 installed when invoke "shutdown when workflow completes" for Admin Server from Admin Console, you will see following exception and Admin Server could not be shut down:

java.lang.NoClassDefFoundError: com/bea/wlcp/wlng/api/plugin/CompletionBarrierCallback

java.lang.NoClassDefFoundError: com/bea/wlcp/wlng/upgrade/UpgradableModule

java.lang.NoClassDefFoundError: com/bea/wlcp/wlng/log/FactoryHierarchy.

There is issue reported when invoking "shutdown when workflow completes" for ATs as well.

Basically the errors seen is when you apply PS3 on a running server some jar files that are set in classpath are updated.

That cause the JVM to loose ‘connection’ to this jar file. I.e it can not read from it anymore. In this case the affected jar file is wlng.jar.

So when server is shutdown some classes located in wlng.jar needs to be loaded into JVM but, since it can not read from the jar file anymore you will see NoClassDefFoundError.

When server is started again all will work and next shutdown will also work.

There is no real good solution to this problem unless to apply PS3 on servers that are already shutdown.

Or please force the shutdown and kill the server process if it hangs.

 

Contacts

To view full details, sign in with your My Oracle Support account.

Don't have a My Oracle Support account? Click to get started!


In this Document
Details
Actions
Contacts
References

My Oracle Support provides customers with access to over a million knowledge articles and a vibrant support community of peers and Oracle experts.