My Oracle Support Banner

'Server Version Does Not Match Unifier Database Version' Error Attempting to Login to Unifier (Doc ID 2002783.1)

Last updated on JULY 11, 2017

Applies to:

Primavera Unifier - Version 9.9 and later
Information in this document applies to any platform.

Purpose

Resolve mismatch error encountered after attempting Unifier patching maintenance.

STEPS TO REPRODUCE
----------------------
1. Access Unifier login page.
2. Error is displayed on login page:

Error: Server Version Does Not Match Unifier Database Version. (with exception)

Error in Unifier server log:

<WebLogicServer> <BEA-000360> <Server started in RUNNING mode>
Connecting to Unifier database...
Current Version: Unifier 10.1.0.0
Previous Version: Unifier 9.14.0.0
Unifier database instance ID: 789XYZ123ABC
Default Time Zone: America/Pacific
SERVER COUNT: 2
Error: server version does not match Unifier database version.
Current version is Unifier 10.1.0.0 (b-09192014-12) but the previous version is Unifier 9.14.0.0 (b-11262014-23)
Exception in thread "Unifier Startup" java.lang.RuntimeException: java.lang.Exception:
Current version is Unifier 10.1.0.0 (b-09192014-12) but the previous version is Unifier 9.14.0.0 (b-11262014-23)

NOTE: SERVER COUNT: value in Unifier log is greater than one (1). This indicates multiple Unifier applications instances are present. Additional information in the server log indicates not all Unifier application instances in the implementation are at the same version of Unifier.

 

Troubleshooting Steps

To view full details, sign in with your My Oracle Support account.

Don't have a My Oracle Support account? Click to get started!


In this Document
Purpose
Troubleshooting Steps
 Cause 1 Failure to upgrade all Unifier application instances
 Cause 2 Failure to deploy new EAR file when performing patch maintenance
References


My Oracle Support provides customers with access to over a million knowledge articles and a vibrant support community of peers and Oracle experts.