My Oracle Support Banner

Enterprise Integration Pack(EIP) 2.2.2 Receive Error, "SncPDLInit()==SNCERR_INIT, Adapter #1 sapcrypto.dll not loaded [sncxxdl_mt 726]" (Unix Only) (Doc ID 2009171.1)

Last updated on MARCH 02, 2019

Applies to:

Oracle Agile Engineering Data Management - Version 6.1.3.0 to 6.1.3.0 [Release 6.1.0]
Information in this document applies to any platform.

Symptoms

On Agile 6.1.3 EIP 2.2.2 HF11

When attempting to run the test program with SAP Connector for Secure Network Communication (SNC) configured, receive error:

*** ERROR => SncPDLInit()==SNCERR_INIT, Adapter #1 (.../sapjco3/sapcrypto.dll) not loaded [sncxxdl_mt 726]
--- Nested Exception ---
com.sap.conn.jco.JCoException: (102) JCO_ERROR_COMMUNICATION: Initialization of repository destination EIGNER_CONNECTION_POOL1299240955 failed: Connect to SAP gateway failed
….
ERROR SncPDLInit()==SNCERR_INIT
  Unable to load GSS-API Shared Library
  named
  ".../sapjco3/sapcrypto.dll"


STEPS TO REPRODUCE

1. Configure EIP , controller DB, connectors as described in the documentation.

2. Set environment variables:
  ORACLE_HOME
  JAVA_HOME

Checked settings
env | grep ORACL
ORACLE_HOME=/oracle/client/11204_32

env | grep JAVA_HOME
JAVA_HOME=/opt/java7

3. Set additional environment variables for using SNC
 SECUDIR
 LD_LIBRARY_PATH
 
4. Start $eai_home/bin/test.sh.

5. Receive error.
  Unable to load GSS-API Shared Library
  named
  ".../sapjco3/sapcrypto.dll"

Cause

To view full details, sign in with your My Oracle Support account.

Don't have a My Oracle Support account? Click to get started!


In this Document
Symptoms
Cause
Solution
 SOLUTION #1 - UPGRADE TO AGILE EDM VERSION 6.2.0.0 OR HIGHER
 SOLUTION #2 - INSTALL 6.1.3.0 (HF0011)
References


My Oracle Support provides customers with access to over a million knowledge articles and a vibrant support community of peers and Oracle experts.