My Oracle Support Banner

Java8 Installed on the Client Machine Causes Error When Trying to Start Oracle Agile e6.1.2.2 Webstart Java Client (Doc ID 2012703.1)

Last updated on JUNE 21, 2018

Applies to:

Oracle Agile Engineering Data Management - Version 6.1.2.2 and later
Information in this document applies to any platform.

Symptoms

On Oracle Agile e6.1.2.2, Webstart Java Client
Find that if Java 8 is installed on the client machine(s) and then the Webstart Java Client of e6.1.2.2 is started, the handover from Java 8 to Java 6 works fine but then an Error appears: "java.lang.IllegalArgumentException: TLSv1.2".
This seems to come from Java 6 not supporting TLSv1.1 and TLSv1.2 but only TLSv1.0.

The issue happens only if the Webstart Java Client is connected through HTTPS protocol.

Expected Behavior:
============
Issue should not occur and Java should start the Oracle Agile e6.1.2.2 Java Client without issues.

The issue can be reproduced with following steps:
===================================
1. Provide the Java Client through https (example: https://exampleserver.exampledomain.com:7104/Jacc)
2. Install JRE 6, JRE 7 and JRE 8 on the client machine from where you want to start the Oracle Agile Java Client
3. Make sure TLSv1.1 and TLS v1.2 are activated in the Java 8 Control Panel
4. Try to start the Oracle Agile Java Client and see the error message


Cause

To view full details, sign in with your My Oracle Support account.

Don't have a My Oracle Support account? Click to get started!


In this Document
Symptoms
Cause
Solution
References


This document is being delivered to you via Oracle Support's Rapid Visibility (RaV) process and therefore has not been subject to an independent technical review.
My Oracle Support provides customers with access to over a million knowledge articles and a vibrant support community of peers and Oracle experts.