Workflow Editor - Paste Is Not Working Any More (Doc ID 2024711.1)

Last updated on MARCH 08, 2017

Applies to:

Oracle Agile Engineering Data Management - Version 6.1.2.2 and later
Information in this document applies to any platform.

Symptoms

On Oracle Agile e6.1.2.2 and e6.1.3 with the Workflow Editor started from the Java Client
Find that it is not possible any more to copy and paste elements from one process into another like it was possible with former versions (e6.1.1). A process needs to be created from scratch (cannot be copied) and can be updated only with elements from the toolbox.

Expected Behavior:
============
Copy and paste actions should work like in former versions again


The issue can be reproduced at will with the following steps:
==========================================
1. Create a process template and add several activities (in the workflow editor - from the toolbox)
2. Save the process template
3. Create a "process in definition" from the process template created in step 1
4. Create another "process in definition" with Insert -> Insert Ad-hoc process from the context menu
5. Load both "processes in definition" into the workflow editor
6. In the workflow editor select several elements from the one process (copied from the process template)
7. Either from the context menu in the process (right mouse) or from the top menu of the WFL editor under the Edit menu selection click "Copy" (or press key combination Ctrl-C)
8. In the empty process either click "Paste" or press key combination Ctrl-V
=> Nothing happens - elements are not copied
If you use "Cut" instead of "Copy", the elements are removed from the original process but on "Paste" nothing happens either.


Changes

 Upgrade from Oracle Agile e6.1.1 to e6.1.2.2 or to e6.1.3

Cause

Sign In with your My Oracle Support account

Don't have a My Oracle Support account? Click to get started

My Oracle Support provides customers with access to over a
Million Knowledge Articles and hundreds of Community platforms