Rapid Planning Forecast Explosion And Spreading Of ATO Models Is Incorrect (Doc ID 2032228.1)

Last updated on JUNE 29, 2017

Applies to:

Oracle Rapid Planning - Version 12.2.4 and later
Information in this document applies to any platform.

Symptoms

On : 12.2.4 version, Planning Engine in Test

Users are on 12.2.4 and have applied VCP 12.2.4.1 - patch 1954953. Key rp files

engine.zip 120.134.12020000.51
RPAdmin.zip 120.5
RPUIDomainTemplate.zip 120.0.12020000.2
ui.zip 120.206.12020000.54

Users run an unconstrained MRP/Mfg plan with Explode enabled as they're using ATO models with Planning % and forecast spreading enabled. However, the forecast qty being shown on a daily basis for an item is showing a decimal value unexpectedly. Example data:

BOM in Org: UBD:PRY (org id = 102)
====
DPM74 - ATO Model (item id = 71)
 - OC-BASE-DPM74 - 1 per - Planning % = 100 (item id = 88)
  - LEFT-BASE-DPM74 - 1 per - Planning % = 60
  - RIGHT-BASE-DPM74 - 1 per - Planning % = 40
There are NO lead times for any of these items

Forecast entered in source MRP for item = DPM74
Qty = 20 due in period bucket 06-JUL-2015
Qty = 20 due in period bucket 03-AUG-2015

After running the plan with Explode enabled and Spread forecast evenly, We started off by looking at the model explode which looks fine and planned 1 per day in both July and August Buckets. We first assumed OC-BASE-DPM74 was fine since the top level ATO model was fine and we saw qty = 0.46 for LEFT-BASE-DPM74 and 0.31 for RIGHT-BASE-DPM74. We were expecting 0.6 and 0.4 respectively. We couldn't figure out where these numbers cam from so we look up at next assembly OC-BASE-DPM74 and found it is creating the problem. This item is 1 per with 100% yield and 100% planning %, but yet it shows 0.77 per day in July and 0.61 per day for August. Hence expected 1 per day for this item just like ATO Model = DPM74

Things we looked at:

A. The plan owning org is UBD:WEI and the forecast is in UBD:PRY so thought of calendar differential. However all orgs assigned the same Mfg calendar = UBP:UP MFG
B. Compared ATO Model vs BASE item in msc_system_items for plan id = 3023 and don't see anything to cause the BASE item to show fraction instead of 1
C. Looked as msc_bom_components for DPM74 and OC-BASE-DPM74 for plan id 3023 and found both have planning % = 100 and component yield factor = 1

STEPS
-----------------------
The issue can be reproduced at will with the following steps:
1. Setup ATO Model with planning % in source
2. Collect data
3. Run RP plan unconstrained with explode = Yes and spread forecast and the spreading looks incorrect at level 1 of the BOM

Cause

Sign In with your My Oracle Support account

Don't have a My Oracle Support account? Click to get started

My Oracle Support provides customers with access to over a
Million Knowledge Articles and hundreds of Community platforms