GCC Libraries Required For MWM/ORS 2.2.0.3 on AIX 7.1 (Doc ID 2037988.1)

Last updated on JUNE 21, 2017

Applies to:

Oracle Utilities Mobile Workforce Management - Version 2.2.0.3.0 and later
Oracle Real-Time Scheduler - Version 2.2.0.3.0 and later
Information in this document applies to any platform.

Goal

The MWM/ORS 2.2.0.3 Installation Guide indicates that GCC 4.2.4 libraries are required for the installation on the AIX 7.1 operation system.  It further states:

GCC 4.2.4

GCC 4.2.4 libraries need to be installed for the scheduler functionality to work properly. The
following GCC runtime libraries are required to be installed:
• libgcc : GCC compiler dynamic runtime library
• libstdc++ : G++ compiler dynamic runtime library

After installing the GCC runtime libraries, copy the following libraries to <INSTALL_DIR>/
runtime directory:
• libstdc++.a
• libgcc_s.a

Alternately, you can add these libraries to LD_LIBRARY_PATH environment variable.

 These libraries are required or the following Scheduler errors will be reported:

However, as noted on the GNU Compiler Collection website, GCC 4.2.4 is not avaiable for AIX 7.1.

Solution

Sign In with your My Oracle Support account

Don't have a My Oracle Support account? Click to get started

My Oracle Support provides customers with access to over a
Million Knowledge Articles and hundreds of Community platforms