Error: "Invalid Or Incompatible Java: Minimum Java Version Required Is 1.7" on the "Patch Progress" Screen of the P6 EPPM Patching Utility to Apply a Patch for P6 EPPM Web Components on Linux/Unix (Doc ID 2075889.1)

Last updated on DECEMBER 01, 2015

Applies to:

Primavera P6 Enterprise Project Portfolio Management - Version 15.1.5.0 and later
Information in this document applies to any platform.

Symptoms

When running the patching utility for P6 EPPM on a linux/unix operating system, at the 97% marker on the Patch Progress screen, the following Patching Error displays:

ERROR
-------
Invalid or Incompatible Java: Minimum java version required is 1.7.

STEPS
-----------------------
The issue can be reproduced at will with the following steps:

  1. Confirm a JAVA_HOME environment variable is set.
  2. Launch the runInstaller for the patching utility.
  3. Complete each of the steps of the patching utility.
  4. Note the error which occurs on the "Patching Progress" screen.

 

Cause

Sign In with your My Oracle Support account

Don't have a My Oracle Support account? Click to get started

My Oracle Support provides customers with access to over a
Million Knowledge Articles and hundreds of Community platforms