Errors and Empty Fields When Running in Production Mode - Segment Roles, Plan Products (Doc ID 2115020.1)

Last updated on JULY 06, 2016

Applies to:

Oracle Insurance Policy Administration J2EE - Version 10.0.0.0 and later
Information in this document applies to any platform.

Symptoms


When running versions 10.1.2.6 in Production mode, the following error occurs:

The same error is thrown for two separate scenarios outlined below.
A third issue of missing role fields does not throw an error but is also outlined below.

Steps to Reproduce
The issue can be reproduced at will with the following steps:
Issue #1
1. Put application in Production mode in the pas.properties file and restart the application.
2. Log in and select a Policy
3. Click Segments.
4. Click on the 1st or 3rd Roles.
5. Notice the error page.
6. Put the application back in Development mode, restart the application.
7. Repeat the steps above
8. Notice there is no error page.

Issue #2
1. Put application in Production mode in the pas.properties file and restart the application.
2. Log in and select an Account
3. Under Plans --> Group Individual --> Plan Products
4. Notice the error page.
5. Put the application back into development mode, restart the application.
6. Repeat the steps and notice there is no error page.

Issue #3
Not consistently reproduced.
1. Put application in Production mode in the pas.properties file and restart the application.
2. Log in and select a Policy and then go to the Products (Segments), notice the Role is there but the fields don't show up.

Cause

Sign In with your My Oracle Support account

Don't have a My Oracle Support account? Click to get started

My Oracle Support provides customers with access to over a
Million Knowledge Articles and hundreds of Community platforms