Error "404 - Page Not Found" When Accessing Agile Web Client and "Can't Connect to X11 Window Server" in Application Server Log (Doc ID 2146851.1)

Last updated on OCTOBER 28, 2016

Applies to:

Oracle Agile Product Collaboration - Version 9.3.4.0 and later
Linux x86-64

Symptoms

When accessing the Agile Web Client, user is getting the following error:

Error

404 - Page not found

Error in ManagedServer and stdout log files

<Error> <HTTP> <BEA-101216> <Servlet: "DashboardExpenseChartServlet" failed to preload on startup in Web application: "/Agile".
java.awt.AWTError: Can't connect to X11 window server using 'XXX' as the value of the DISPLAY variable.
at sun.awt.X11GraphicsEnvironment.initDisplay(Native Method)
at sun.awt.X11GraphicsEnvironment.access$200(X11GraphicsEnvironment.java:65)
...
<Error> <Deployer> <BEA-149231> <Unable to set the activation state to true for the application "AgilePLM".
weblogic.application.ModuleException: java.awt.AWTError: Can't connect to X11 window server using 'XXX' as the value of the DISPLAY variable.
at weblogic.application.internal.ExtensibleModuleWrapper.start(ExtensibleModuleWrapper.java:140)
at weblogic.application.internal.flow.ModuleListenerInvoker.start(ModuleListenerInvoker.java:124)
...
Caused By: java.awt.AWTError: Can't connect to X11 window server using 'XXX' as the value of the DISPLAY variable.
at sun.awt.X11GraphicsEnvironment.initDisplay(Native Method)"

 

Fact:

Agile PLM Failed to deploy in Weblogic
Agile Application Server is running on Linux server

 

Cause

Sign In with your My Oracle Support account

Don't have a My Oracle Support account? Click to get started

My Oracle Support provides customers with access to over a
Million Knowledge Articles and hundreds of Community platforms