Incident Symbol Incorrectly Showing When Using A Call That Does Not Have A Clue/symbol Defined (Doc ID 2185760.1)

Last updated on OCTOBER 19, 2016

Applies to:

Oracle Network Management for Utilities - DMS - Version 1.12.0.3 to 1.12.0.3 [Release 1.12]
Oracle Utilities Network Management System - Version 1.12.0.3 to 1.12.0.3 [Release 1.12]
Information in this document applies to any platform.

Symptoms

On : 1.12.0.3 version, Web Workspace

If you send a call that has a clue with symbol of 0, the viewer shows a phone symbol.

 

The expected behavior is that since the call has a clue, the viewer should attempt to show it, but since its symbol is 0, it should draw nothing.

(If you send a call that has no clues, the viewer does not show anything.   If you send a call that has one or more clues, the viewer shows the highest priority clue. In either case, the viewer does not show a phone symbol.)

 

The call symbol should not get displayed if it has no clues and Call Display is not on


To reproduce the issue on an OPAL system:

Start Web Call Entry.
Submit a call for "ALVIN + FRANCES P BARBER" with these settings:
Power:  All Power Out
Cause: Other/See Remarks

Start Web Workspace
In the Authority tool, subscribe to all zones
Start a viewer
Search for device T20929


The phone symbol will appear - even though the trouble code for the clue has a symbology of 0.



INSERT INTO  srs_trouble_codes  VALUES ('Cause', 2, 'Other/See Remarks', 'default', 8, 0, '', 'Other', 1, 1, 0, '');

Changes

 

Cause

Sign In with your My Oracle Support account

Don't have a My Oracle Support account? Click to get started

My Oracle Support provides customers with access to over a
Million Knowledge Articles and hundreds of Community platforms