Cannot Control Display Of Attributes In MCAD User Interface Since Upgrade To MCAD 3.5

(Doc ID 2196543.1)

Last updated on SEPTEMBER 28, 2017

Applies to:

Oracle Agile PLM MCAD Connector - Version 3.3.0 to 3.5.0 [Release 3.3.0 to 3.5.0]
Information in this document applies to any platform.

Symptoms

On MCAD 3.5.0 SolidWorks Connector The Preferences dialog presents the tabs to configure the visibility and access to each subclass' attributes. The User Interface behaves as if the attributes could be configured, but saving the modifications does not have any effect.
There is no note in the What's New documentation other than the fact that the Attributes.xml is no longer used. Regardless, this feature is very important for the usability of the product.

Steps to Reproduce:

  1. Open the Preferences window by pressing on the "Preferences" button in the Agile menu. Login to Agile.
  2. Select Design tab and disable some attributes in the Table.
  3. Save the changes.
  4. Go back to the Preferences window and check the Attributes that you have changed. In theory, they should be disabled but they are still enabled, which means that the changes were not saved.
  5. See Below screenshots descriptions:

 

      

From SolidWorks go to tools --> Agile --> Connect to Agile --> Go to Preferences Window

Select Design tab then disable some attributes, any attributes you want (disable the two columns):

 

Save the changes. Notices that a new copy of the preferences.xml file was created in Agile which is expected.
Disconnect from Agile, close SolidWorks then reopen.
Go back to the preferences window , look at the attributes changes you made, they are gone! (the changes that are made did not take effect)

 

Cause

Sign In with your My Oracle Support account

Don't have a My Oracle Support account? Click to get started

My Oracle Support provides customers with access to over a
Million Knowledge Articles and hundreds of Community platforms