Upgrade From 2.2.1.8 To 2.4.6: Invalid Database Objects On LSH 2.4.0 and Unable To Install Work Area (Doc ID 2205113.1)

Last updated on MARCH 08, 2017

Applies to:

Oracle Life Sciences Data Hub - Version 2.4 and later
Information in this document applies to any platform.

Symptoms

Invalid Database Objects On LSH 2.4.0 and Unable To Install Work Area.  The invalid Objects are as follows:

1. CDR_DEF_FACTORY_DELETE APPS
2. CDR_PUB_API_GVA APPS
3. CDR_PUB_DF_TABLE APPS
4. CDR_BIP11G_SERVICES CDR_WA2B_91C4BDF3_1

STEPS TO UPGRADE
--------------------------------
1) What releases are you upgrading from / to?

Upgrade Map
____ LSH 2.2.1.9 (22074042)
____ LSH 2.2.1.10 (22298008)
____ LSH 2.2.1.11 (22535936 )
____ Upgrade Database to 11.2.0.4 (Include Interop eBS)
____ Upgrade to LSH 2.2.2 (19310436)
____ Upgrade LSH to 2.3.0 (14257370)
____ Upgrade TMS to 4.6.2
____ Upgrade TMS to 5.0.1
____ Upgrade to LSH 2.3.1 (16935540)
____ Upgrade LSH to 2.4.0 (16935545)
 -- up to 2.4.6.7 --
 
After each patch they are applying the following steps:
____ run cdradaptergrants.sql
____ stop OWB
____ update OWB (jars and install*.sh)
____ start OWB
____ LSH LOB Concurrent Program End Successful with no errors in log
____ LSH POST Install Program End Successful with no errors in log


ERRORS WHEN COMPILING PACKAGES
-----------------------------------------------------------------

____ LSH LOB Concurrent Program End Successful with no errors in log
____ LSH POST Install Program End Successful with no errors in log

1. CDR_DEF_FACTORY_DELETE
_______/* $Header: cdrdffactdelb.pls 120.36 2014/02/05 08:32:56 dkallavi noship $*/
_______/* $Header: cdrdffactdels.pls 120.3.12000000.3 2014/04/11 06:47:14 pumesh noship $*/
_______Error(21,14): PLS-00323: subprogram or cursor 'UNDOCHECKOUT' is declared in a package specification and must be defined in the package body
_______Error(2506,16): PLS-00307: too many declarations of 'UNDOCHECKOUT' match this call
_______Error(2506,16): PL/SQL: Statement ignored

2. CDR_PUB_API_GVA
_______* $Header: cdrpubapigvab.pls 120.33 2014/04/11 10:50:36 ctankasa noship $*/
_______/* $Header: cdrpubapigvas.pls 120.1.12000000.2 2014/06/03 20:44:10 jakrupa noship $*/
_______Error(119,14): PLS-00323: subprogram or cursor 'MANAGEBAACCESS' is declared in a package specification and must be defined in the package body

3. CDR_PUB_DF_TABLE
_______/* $Header: cdrpubdftables.pls 120.2.12000000.3 2014/05/28 10:35:53 pumesh noship $ */
_______/* $Header: cdrpubdftableb.pls 120.7 2013/02/21 09:41:37 arugovin noship $ */
_______Error(627,11): PLS-00323: subprogram or cursor 'UNDOCHECKOUT' is declared in a package specification and must be defined in the package body

4. CDR_BIP11G_SERVICES
____/* $Header: cdrbip11gadpb.txt 120.0.12000000.2 2014/07/15 08:45:07 pumesh noship $*/
____/* $Header: cdrbip11gadps.txt 120.0.12000000.2 2014/07/15 08:41:52 pumesh noship $*/
____Error(201,3): PLS-00201: identifier 'CDR_EXE_DEBUG_PKG' must be declared



Changes

Upgrading from LSH 2.2.1.8 on DB 11.2.0.3 to LSH 2.4.6.1.7 on DB 11.2.0.4.


On the middle of upgrade (on 2.4.0 with 11.2.0.4) they have 4 invalid database objects and not able to install Work Areas.

Cause

Sign In with your My Oracle Support account

Don't have a My Oracle Support account? Click to get started

My Oracle Support provides customers with access to over a
Million Knowledge Articles and hundreds of Community platforms