Create Criteria Using "User" Subclass "User Groups.Group Name" Missing In Agile PLM 9.3.5

(Doc ID 2210167.1)

Last updated on DECEMBER 02, 2016

Applies to:

Oracle Agile PLM Framework - Version 9.3.4.0 and later
Information in this document applies to any platform.

Symptoms

On Agile PLM 9.3.5.0 version, Administration/Configuration . The administrator is trying to create some criteria using "Group Name" but the field seems to no longer be available. This criteria was available in 9.3.2 . The administrator is attempting to create some criteria and subsequent list attribute where the only available users are in a specific user group.

 

 

In Agile PLM 9.3.2 the Criteria "User Groups.Group Name" exists.

In Agile PLM 9.3.4 or higher the Criteria "User Groups.Group Name" no longer exists.


Expected Behavior
---------------------
The administrator should be able to use " User Groups.Group Name" criteria

Steps to Reproduce
----------------------
The issue can be reproduced at will with the following steps:

  1. Logged into a generic 9.3.5 system
  2. Created a new User group "UG1" and added a few user's to it
  3. Went to the Admin || Data Settings || Criteria Node
  4. Created a new criteria 'UserGrpCriteria"
  5. Selected Object Type 'User'
  6. Attributes 'User Group.Group Name' In 'UG1' is not available

 

Cause

Sign In with your My Oracle Support account

Don't have a My Oracle Support account? Click to get started

My Oracle Support provides customers with access to over a
Million Knowledge Articles and hundreds of Community platforms