My Oracle Support Banner

Error :".NET Framework 4.5 or later is not installed on this environment. This installer requires. NET Framework 4.5 or later, please install" When Trying to Install MCAD 3.4 on Windows 10 Operating System (Doc ID 2212728.1)

Last updated on FEBRUARY 21, 2019

Applies to:

Oracle Agile PLM MCAD Connector - Version 3.4.0 and later
Information in this document applies to any platform.

Symptoms

The Administrator is not able to Install MCAD Creo 3.4 on Windows 10 Operating System machine.  As windows 10 comes with default .NET 4.6 Framework. They cannot install .NET 4.5.

When he tries to run the installer he gets this error :

 

No Compatible .NET Framework version Available.

.NET Framework 4.5 or later is not installed on this environment. This installer requires. NET Framework 4.5 or later, please install

 

When he tries to install .NET Framework 4.5 he gets the following error :



Steps to Reproduce:

Try to install MCAD connector 3.4 in Windows 10 Operating System. The installer will fail with the error mentioned above.

BUSINESS IMPACT
-----------------------
The issue has the following business impact:
Installation/Setup Issue

Changes

 

Cause

To view full details, sign in with your My Oracle Support account.

Don't have a My Oracle Support account? Click to get started!


In this Document
Symptoms
Changes
Cause
Solution
References


My Oracle Support provides customers with access to over a million knowledge articles and a vibrant support community of peers and Oracle experts.