Usage Product Price Update From $0 To $2 Not Reflected In Existing CM Connections (Doc ID 2214001.1)

Last updated on DECEMBER 26, 2016

Applies to:

Oracle Communications Billing and Revenue Management - Version 7.5.0.0.0 and later
Information in this document applies to any platform.

Symptoms

On : 7.5.0.15.0 version, CM

Issue is that usage product's price changed from $0 to $2 for a product, is  not reflected in existing CM connections

ACTUAL BEHAVIOR
---------------
Usage rating is not considering the updated price , it still using the old price.

EXPECTED BEHAVIOR
-----------------------
Usage rating should consider the updated product price without restarting the cm process.

STEPS
-----------------------
The issue can be reproduced at will with the following steps:

1. Created an account with default Plan1.
2. Pass the usage via testnap and left the testnap session as it is.
3. Changed the pricing of of plan1 [ /service/ip usage].
4. Pass the usage again in existing testnap, it rates with old rates.
5. opened another Unix session, pass the usage via testnap and able to see the rating with new price. NOTE: a new child CM got created for this testnap

NOTE:
1)  "fm_rate refresh_product_interval" was not set.

2)  User has a requirement to update usage product pricing in Production without having to restart BRM services, and this issue is preventing that to be fulfilled.
3)  Customer is using JCA adapter, so it will be using connection pool

Changes

 

Cause

Sign In with your My Oracle Support account

Don't have a My Oracle Support account? Click to get started

My Oracle Support provides customers with access to over a
Million Knowledge Articles and hundreds of Community platforms