Configuration Issue After Applying Tools And Frameworks Patch 24564805 (Doc ID 2243547.1)

Last updated on MARCH 31, 2017

Applies to:

Oracle Commerce Guided Search / Oracle Commerce Experience Manager - Version 3.1.2 and later
Information in this document applies to any platform.

Symptoms

App configuration issue after applying Tools and Frameworks patch 24564805

The Tools patch included updating the spring jars in the app's config/lib/java folder.

From patch's README.txt :

8) Replace the spring-2.5.6.jar file in /config/lib/java with the
  version 4.2.5 Spring jar files found in
  <ENDECA_TOOLS_ROOT>/deployment_template/app-templates/common/config/lib/java
  e.g. spring-beans-4.2.5.RELEASE.jar,
  spring-context-4.2.5.RELEASE.jar, spring-core-4.2.5.RELEASE.jar,
  spring-expression-4.2.5.RELEASE.jar

After this, running any command from the control folder will return the below error message:

Changes

 Recently, patch 24564805 was applied.

Cause

Sign In with your My Oracle Support account

Don't have a My Oracle Support account? Click to get started

My Oracle Support provides customers with access to over a
Million Knowledge Articles and hundreds of Community platforms