Allocation ID Runs Successfully On The Server Side But There Is No Result Data (Doc ID 227177.1)

Last updated on JUNE 18, 2008

Applies to:

Oracle Financial Services Applications (OFSA) 4.5
Oracle Profitability Manager - Version: 4.5
This problem can occur on any platform.

Symptoms

In Performance Analyzer 4.5, an Allocation ID process runs successfully on the server side (using the OFSA Knowledge engine "ofspa) without client interaction but there is no result data.  The Allocation ID process runs successfully on the client side and has correct results.  When checking the ofsa_result_queue table that stores job information, there is no result data and the "As Of Date" in the Undo screen does not have the correct date.

SQL from running a trace:

select count(*) from ACT_COST a where (((a.ID_NUMBER >= '
1100000001' and a.ID_NUMBER <= ' 1100000101'))) and
a.as_of_date='01/01/1900'

and

select distinct a.COMMON_COA_ID from LEDGER_STAT a where
a.FINANCIAL_ELEM_ID=100001 and a.ORG_UNIT_ID=1001 and a.ACTIVITY_ID=200001
and a.year_s IN (1900) order by a.COMMON_COA_ID

The As of Date used by the engine is 01/01/1900.

The Parameter File used to launch the Allocation on the server is as follows:

2356 -> Job Number
OFSA45 -> DBAlias
OFSA45 -> UserName 
xxxxxx -> Password
101490 -> ProdID (sys_id_num of allocation ID)
0 -> ID Type
'08-31-01' -> As Of Date

Cause

Sign In with your My Oracle Support account

Don't have a My Oracle Support account? Click to get started

My Oracle Support provides customers with access to over a
Million Knowledge Articles and hundreds of Community platforms