Upgrade from 2.4.6.14 to 2.4.7.0 : CDR_PUB_API_GVA and DME_DF_MODEL_INSTALL invalid (Doc ID 2272958.1)

Last updated on JUNE 01, 2017

Applies to:

Oracle Health Sciences Data Management Workbench - Version 2.4.6 to 2.4.6 [Release 2.4]
Information in this document applies to any platform.

Symptoms

Upgrading from 2.4.6.12 to 2.4.7.0, and the following invalid objects were found after the upgrade:

-
CDR_PUB_API_GVA
Error: Error(196,10): PLS-00323: subprogram or cursor 'GETCUSTOMLISTINGBA'
is declared in a package specification and must be defined in the package
body
-
DME_DF_MODEL_INSTALL
Error:
Error(1483,18): PLS-00302: component 'SYNCHSEC2PRIBASYNONYMS' must be
declared
-

The script "upgrade_gvabas.sql" as part of the 2.4.7 release notes failed with the following error, see below. 

-bash-3.2$ sqlplus apps/apps @upgrade_gvabas.sql

SQL*Plus: Release 10.1.0.5.0 - Production on Wed May 24 07:43:49 2017

Copyright (c) 1982, 2005, Oracle. All rights reserved.

Connected to:
Oracle Database 11g Enterprise Edition Release 11.2.0.4.0 - 64bit Production
With the Partitioning, OLAP, Data Mining and Real Application Testing options

Please enter the name of a log file to save the output of this script.
Filename: [upgrade_gvabas.log]
dme_auto_ba.createDiscsViewInBA(rec.schema_name,
x_ret, x_ct, x_data);
*
ERROR at line 29:
ORA-06550: line 29, column 4:
PLS-00306: wrong number or types of arguments in call to
'CREATEDISCSVIEWINBA'
ORA-06550: line 29, column 4:
PL/SQL: Statement ignored

SQL> exit

 

 

Cause

Sign In with your My Oracle Support account

Don't have a My Oracle Support account? Click to get started

My Oracle Support provides customers with access to over a
Million Knowledge Articles and hundreds of Community platforms