Few Entities Not Getting Collected In Legacy Collection (Doc ID 2278813.1)

Last updated on JULY 18, 2017

Applies to:

Oracle Advanced Supply Chain Planning - Version 12.1.3.9 and later
Information in this document applies to any platform.

Symptoms

ACTUAL BEHAVIOR

Certain entities not getting collected in Legacy collection

While running collections from Legacy instance in our Production instance, certain entities get loaded to the staging tables but remain with process_flag = 2 and do not get collected into ODS. Our current number of workers for this run of collections is 25. As a result customer has to rerunning collections as part of the daily cycle to recollect the WIP entities. Missing data gets collected during the 2nd run of data collection.

Some of the entities affected include:
- WIP component demands
- Resource requirements
- Work order supplies

Customer tried to replicate the issue changing the number of workers = 1 in Prod and the entities are getting collected successfully. On increasing the workers to 3 or 8, the same entities remain in the staging table with process_flag = 2.


EXPECTED BEHAVIOR

All qualified data should be collected into target tables.

STEPS
-----------------------
The issue can be reproduced at will with the following steps:
1. Run legacy data collection with no.of workers > 1


Cause

Sign In with your My Oracle Support account

Don't have a My Oracle Support account? Click to get started

My Oracle Support provides customers with access to over a
Million Knowledge Articles and hundreds of Community platforms