Importing a P6 XML Project Multiple Times at Once Generates the Same Project ID for All Imported Projects (Doc ID 2282877.1)

Last updated on JULY 18, 2017

Applies to:

Primavera P6 Enterprise Project Portfolio Management - Version 16.1.4.0 and later
Information in this document applies to any platform.

Symptoms

ACTUAL BEHAVIOR

After importing a large P6 XML project into P6 Professional twice, both of the imported projects are listed with same Project ID.

(This issue can only be reproduced using projects with at least 5000 activities.)

 

EXPECTED BEHAVIOR

All projects must have an unique Project ID.


The issue can be reproduced at will with the following steps:

  1. In P6 Professional, select File > Import from the menu and import the P6 XML project.
  2. Once the import has started, select File > Import again and import the same P6 XML project.
  3. Select Tools > Job Status and monitor the jobs until they complete successfully.
  4. View the Projects list and note the duplicate Project ID.

 

Changes

 

Cause

Sign In with your My Oracle Support account

Don't have a My Oracle Support account? Click to get started

My Oracle Support provides customers with access to over a
Million Knowledge Articles and hundreds of Community platforms