"Unable To Start XAI Server" While Submitting Seeded XAI Inbound Request From XAI Submission (Doc ID 2305454.1)

Last updated on SEPTEMBER 11, 2017

Applies to:

Oracle Real-Time Scheduler - Version 2.3.0.1.0 and later
Oracle Utilities Mobile Workforce Management - Version 2.3.0.1.0 and later
Information in this document applies to any platform.

Goal

We have recently upgraded from ORS 2.1.0.5 to 2.3.0.1

When submitting a request through XAI submission window for any seeded XAI inbound service request, we get a null response (blank page) and the following error is visible in the weblogic_current.log

 

Qn1) User have checked in a ORS 2.1.0.5 environment and the value for prefer-web-inf-classes in the template file weblogic.xml.XAIApp.template is set to true. Also there is no custom template cm.weblogic.xml.XAIApp.template for the template file in that environment, however XAI Submission is working in that environment. Why is it not working in the upgraded environment then with similar settings?
 
2) Should user continue to have 'prefer-web-inf-classe's set to 'false' in the custom template cm.weblogic.xml.XAIApp.template? Would there be any adverse impact of this?

3) If this is the solution, when would you be able to provide a permanent fix for this?


 

Solution

Sign In with your My Oracle Support account

Don't have a My Oracle Support account? Click to get started

My Oracle Support provides customers with access to over a
Million Knowledge Articles and hundreds of Community platforms