Value Is Not Displayed In Validation Message When Using A MV With An '_' Between $$$

(Doc ID 2337423.1)

Last updated on DECEMBER 08, 2017

Applies to:

Oracle Insurance Policy Administration J2EE - Version 11.0.2.6 and later
Information in this document applies to any platform.

Symptoms

On : 11.0.2.6 version, General

ACTUAL BEHAVIOR
---------------
Value is not displayed in validation message when using a MathVariable with an Underscore Character between $$$. We are trying to display the value of a MathVariable in an error message triggered by OnChange/OnSubmit. If the MathVariable Name has an underscore in it, the value is not picked up when inserted between the $$$’s. Example configuration will be attached.

EXPECTED BEHAVIOR
-----------------------
When fields with underscores are used inside validation messages their values will be displayed on the screen.

STEPS
-----------------------
The issue can be reproduced at will with the following steps:
1) Configure a screen math variable to have an underscore in, inside an activity
2) Configure a validation to trigger on an event (This can be on anything)
2a) in the Action portion have an 'Error' to be shown where the message includes the MV with an underscore it
3) Navigate to a policy in OIPA where you can add the activity
4) Get the validation to trigger and notice the value will not be displayed on the screen.

BUSINESS IMPACT
-----------------------
The issue has the following business impact:
Due to this issue, it goes against the configuration standard that we have put in place for how to name math variables

Cause

Sign In with your My Oracle Support account

Don't have a My Oracle Support account? Click to get started

My Oracle Support provides customers with access to over a
Million Knowledge Articles and hundreds of Community platforms