Can Java 1.8 Be Used For A Cartridge With ASAP 7.2.0 ?

(Doc ID 2339035.1)

Last updated on DECEMBER 20, 2017

Applies to:

Oracle Communications ASAP - Version 7.2.0 to 7.2.0 [Release 7.2]
Information in this document applies to any platform.

Goal

We are having an SSL issue with a single downstream interface. The issue is related to TLSv1.2 vs TLSv1. The interface is contained within a cartridge developed for ASAP.

[javax.net.ssl.SSLHandshakeException: Received fatal alert: handshake_failure]

When we run with Java 1.8 (versus 1.7), the problem appears to be resolved.

Are there any known problems with using Java 1.8 with ASAP 7.2.0?
 

Solution

Sign In with your My Oracle Support account

Don't have a My Oracle Support account? Click to get started

My Oracle Support provides customers with access to over a
Million Knowledge Articles and hundreds of Community platforms