My Oracle Support Banner

Naming Conflict And Un-supported Drools Plugin Problems When Upgrading Design Studio From 7.3.4 TO 7.3.5.0 (Doc ID 2358855.1)

Last updated on FEBRUARY 28, 2019

Applies to:

Oracle Communications Design Studio - Version 7.3.5.0.0 to 7.3.5.0.0 [Release 7.3.0]
Information in this document applies to any platform.

Symptoms

We are using our cartridges with Design Studio version 7.3.4. When we upgrade Design Studio from 7.3.4 to 7.3.5.0 the model cartridges are getting upgraded. After this , the build of the  cartridges is failing due to conflicts in model cartridges and model cartridges are sealed cartridges.

The Build errors are -
Naming Conflict - Entity names must be unique (case-insensitively) amongst other entities of the same or similar types within a workspace. The conflicts are: /OracleComms_Model_Base/model/PartnerGateway.applicationRole PartnerGateway.applicationRole /OracleComms_Model_BaseCatalog/model Unknown Problem

Un-supported drools plugin - The drools plug-in for the selected application target version "7.3.4" should be "5.5", but the installed plug-in version is "6.5.0.Final". OracleComms_UIM_BaseCatalog.inventoryCartridge /OracleComms_UIM_BaseCatalog Unknown Problem

Changes

 

Cause

To view full details, sign in with your My Oracle Support account.

Don't have a My Oracle Support account? Click to get started!


In this Document
Symptoms
Changes
Cause
Solution
References


My Oracle Support provides customers with access to over a million knowledge articles and a vibrant support community of peers and Oracle experts.