Error During Rolling Upgrade After Updating From ECE 11.3 PS4 To ECE 11.3 PS5

(Doc ID 2364315.1)

Last updated on MARCH 06, 2018

Applies to:

Oracle Communications BRM - Elastic Charging Engine - Version 11.3.0.5.0 and later
Information in this document applies to any platform.

Goal

In ECE 11.3 Patchset 5;

Persistence feature for ReplicatedFederatedCache and XRefFederatedCache is introduced in this version and it is causing an issue.
That is, as per ECE installation guide, it is mentioned to follow the configuration with respect to persistence to be enabled in ece.properties file.

java.property.ece.persistence.mode=on-demand
java.property.ece.persistence.mode=active


But while performing rolling upgrade post the PS5 installation following error is thrown :


  
Question:

The above mentioned persistence-environments configuration was not mentioned in the upgrade/installation guide. Is the above workaround, the correct approach?
 

Solution

Sign In with your My Oracle Support account

Don't have a My Oracle Support account? Click to get started

My Oracle Support provides customers with access to over a
Million Knowledge Articles and hundreds of Community platforms