Electrical Maps Do not Load Consistently When Loading Switch Plan View Areas

(Doc ID 2387435.1)

Last updated on APRIL 23, 2018

Applies to:

Oracle Utilities Network Management System - Version 1.12.0.3 to 2.3.0.2.0 [Release 1.12 to 2.3]
Oracle Network Management for Utilities - DMS - Version 1.12.0.3 to 2.3.0.1.0 [Release 1.12 to 2.3]
Information in this document applies to any platform.

Symptoms

Occasionally, loading a View Area via a Switch Sheet does not load the electrical maps.
It seems that if "Unload Maps" was performed before loading the view area, only the background maps get loaded.


The electrical layer should be getting loaded as well.

The issue can be reproduced at will with the following steps:

NOTE: "viewer.auto_load_on_focus" must be set to "false"
  1. Launch a Web Workspace with Web Switching environment.
  2. Create a new Planned Switch sheet
  3. Record placing and removing a tag on a switch
  4. Target to the device in viewer 1
  5. Zoom out several times and pan several times to the right
  6. In Web Switching > View Areas, press the Camera 1 button to create a new View Area
  7. Save your switch sheet
  8. Select the "All Devices (Dynamic View)" entry and press the "Load Selected View Area into Viewer 1" button.
  9. The device gets displayed in the viewer
  10. Unload all maps
  11. Select the new View Area entry  ( "View Area ####" ) and press the "Load Selected View Area into Viewer 1" button.
  12. Only the background maps get loaded.

 

Changes

In $NMS_CONFIG/jconfig/ops/viewer/xml/VIEWER_GLOBAL_PROPERTIES.inc, set "auto_load_on_focus" to false:

Cause

Sign In with your My Oracle Support account

Don't have a My Oracle Support account? Click to get started

My Oracle Support provides customers with access to over a
Million Knowledge Articles and hundreds of Community platforms