Upgrading Primavera Gateway Of An Earlier Version (e.g. 15.2) To 17.x Fails With Error "update paramvalue set value ..."

(Doc ID 2396476.1)

Last updated on MAY 17, 2018

Applies to:

Primavera Gateway - Version 15.1.0.0 and later
Information in this document applies to any platform.

Symptoms

When attempting to upgrade Primavera Gateway from an earlier version (e.g. v15.2) to 17.12, the following error occurs.

ERROR
-----------------------
"Error when executing this statement: update paramvalue set value='http://docs.oracle.com/cd/E80548_01/help' where param_id in (select param_id from param where param_name='general.HelpURLRoot')"




STEPS
-----------------------
The issue can be reproduced at will with the following steps:

1. Upgrade the Oracle database application to a certified version (Oracle 12.2.0.1) for Primavera Gateway 17.12. Or to achieve the certification, migrate (Export/Import) the Gateway database of an earlier version to the certified Oracle database 12.2.0.1.
2. Execute installGateway.bat (.sh on Linux) to start the schema upgrade of Primavera Gateway database.
3. The Gateway installation wizard completed 100%. But the Weblogic domain comes up with above error. And when updating the new gateway.ear file, the weblogic console pops up the same error.

BUSINESS IMPACT
-----------------------
The issue has the following business impact: Due to this issue, users cannot upgrade Primavera Gateway from an earlier version (e.g. v15.2) to 17.12.

Changes

 

Cause

Sign In with your My Oracle Support account

Don't have a My Oracle Support account? Click to get started

My Oracle Support provides customers with access to over a
Million Knowledge Articles and hundreds of Community platforms