My Oracle Support Banner

What Version of the HTTPClient JAR Should BRM be Using? (Doc ID 2411946.1)

Last updated on JUNE 20, 2018

Applies to:

Oracle Communications Billing and Revenue Management - Version 7.5.0.19.0 and later
Information in this document applies to any platform.

Goal

After installing/patching Oracle Communications Billing and Revenue Management (BRM) to 7.5.0 patchset 19, the scripts in ${PIN_HOME}/bin which use the HTTPClient JAR use different versions.  Currently they are hardcoded to use:

load_pin_device_permit_map → httpclient-4.4.jar
load_pin_device_state      → httpclient-4.4.jar
loadpricelist              → httpclient-4.4.jar
pin_amt                    → httpclient-4.5.3.jar
pin_ctl                    → httpclient-4.5.3.jar:
pin_job_executor           → httpclient-4.4.jar
pin_sepa                   → httpclient-4.4.jar
start_batch_controller     → httpclient-4.5.3.jar
start_rel_daemon           → httpclient-4.5.3.jar
storableclasstoxml         → httpclient-4.4.jar

What is the correct version of the HTTPClient JAR which the scripts should be using?

Solution

To view full details, sign in with your My Oracle Support account.

Don't have a My Oracle Support account? Click to get started!


My Oracle Support provides customers with access to over a million knowledge articles and a vibrant support community of peers and Oracle experts.