My Oracle Support Banner

No Option to Choose Oracle Database 12 for BRM 7.5 PS21 Installation (Doc ID 2421370.1)

Last updated on AUGUST 13, 2018

Applies to:

Oracle Communications Billing and Revenue Management - Version 7.5.0.21.0 and later
Information in this document applies to any platform.

Goal

The user is trying to install BRM 7.5PS21 on a Linux system with Oracle Database 12, but there is no option to choose Oracle Database 12, only the option to choose Oracle Database 11.

If continue with the installation, at the moment to start the DM_ORACLE, there is the error:

dm_oracle/dm_oracle11g64.so": libdbt7212d.so: wrong ELF class: ELFCLASS32

Following the possible solution provided by the <Note 1500046.1> and verified these links are already exist:

> ln -s /usr/local/lib/libstdc++.so.5 /usr/lib/libstdc++.so.5
ln: failed to create symbolic link ‘/usr/lib/libstdc++.so.5’: File exists
> ln -s /usr/local/lib/libgcc_s.so.1 /usr/lib/libgcc_s.so.1
ln: failed to create symbolic link ‘/usr/lib/libgcc_s.so.1’: File exists


The environment variables are also verified to pointing to the 32-bit Oracle client:

> echo $LD_LIBRARY_PATH
/brm/app/no1/7.5/lib:/brm/app/nodo1/7.5/lib64:/u01/app/oracle/product/12.2.0/client:/u01/app/oracle/product/12.2.0/client_32/lib

 

Solution

To view full details, sign in with your My Oracle Support account.

Don't have a My Oracle Support account? Click to get started!


My Oracle Support provides customers with access to over a million knowledge articles and a vibrant support community of peers and Oracle experts.