My Oracle Support Banner

LBYPROC Promote Does Not Work On Enterprise Edition Linux Box But Works On Standard Edition (Doc ID 2435256.1)

Last updated on SEPTEMBER 18, 2019

Applies to:

Oracle Documaker Desktop - Version 12.4 and later
Information in this document applies to any platform.

Symptoms

I have been trying to run lbyproc on our Linux box on the enterprise edition but whenever it tries to search for libjvm.so it says it does not exist. So i placed it on the standard edition box and ran it there and it worked.

Enterprise Edition Path:
/opt/oem/13.2/agent_13.2.0.0.0/jdk/jre/lib/amd64/server

Standard Edition Path:
/opt/oem/12.1/core/12.1.0.4.0/jdk/jre/lib/i386/server

Enterprise Edition Script:
#!/bin/bash
#
# Module : lbyproc_test.sh
# Purpose : script to run lbyproc promote
#
#
###################################################################
###################################################################
LD_LIBRARY_PATH=/opt/oracle/odee_1/documaker/bin:/opt/oem/13.2/agent_13.2.0.0.0/jdk/jre/lib/amd64/server
export LD_LIBRARY_PATH

PATH=/opt/oracle/odee_1/documaker/bin:$PATH
export PATH

#Run lbyproc executable
lbyproc /TEST /T /INI=/home/documaker/fsisys.ini /I=/usr/local/stagelib/t.lsc


Standard Edition
#!/bin/bash
#
# Module : lbyproc_test.sh
# Purpose : script to run lbyproc promote
#
#
###################################################################
###################################################################
LD_LIBRARY_PATH=/opt/rel124/bin:/opt/oem/12.1/core/12.1.0.4.0/jdk/jre/lib/i386/server
export LD_LIBRARY_PATH
PATH=/opt/rel124/bin:$PATH
export PATH

#Run lbyproc executable
lbyproc /TEST /T /INI=/home/documaker/fsisys.ini /I=/usr/local/stagelib/t.lsc

Cause

To view full details, sign in with your My Oracle Support account.

Don't have a My Oracle Support account? Click to get started!


In this Document
Symptoms
Cause
Solution


My Oracle Support provides customers with access to over a million knowledge articles and a vibrant support community of peers and Oracle experts.