My Oracle Support Banner

NMS Patch Installation Fails With "The preinstall program exited with an error." (Doc ID 2437911.1)

Last updated on FEBRUARY 26, 2019

Applies to:

Oracle Network Management for Utilities - DMS - Version 1.12.0.3 to 2.3.0.2.0 [Release 1.12 to 2.3]
Oracle Utilities Network Management System - Version 1.12.0.3 to 2.3.0.2.0 [Release 1.12 to 2.3]
Information in this document applies to any platform.

Symptoms

On : 1.12.0.3 version, Installation

Attempt to install latest patch bundle is failing with this error:

>./nms-install
Preparing to install ...
Running NMS prerequisite checks ...
Skipping prerequisite software checks...
Running the NMS installer ...
Logging to /home/build1203/tmp/network/install.log.
Performing pre-installation tasks.
Error! Install package (1.12.0.3.35) does not match the
service pack for the installed software (1.12.0.3.33).
Exiting...
The preinstall program exited with an error

 

Install package (1.12.0.3.35) does not match service pack for the installed software (1.12.0.3.33).

Note that this would also apply to the 2.3.0.0.14, 2.3.0.1.9, 2.3.0.2.3 and 2.3.0.2.4


The issue can be reproduced with the following steps:
1. Set system up at 1.12.0.33B
2. Apply patch bundle 1.12.0.3.35

Cause

To view full details, sign in with your My Oracle Support account.

Don't have a My Oracle Support account? Click to get started!


In this Document
Symptoms
Cause
Solution
 Fix Description
 Workaround
References


My Oracle Support provides customers with access to over a million knowledge articles and a vibrant support community of peers and Oracle experts.