My Oracle Support Banner

Unable to Authorize User groups with Tomcat 8.0.58 (Doc ID 2442566.1)

Last updated on OCTOBER 25, 2019

Applies to:

Oracle Financial Services Analytical Applications Infrastructure - Version 8.0.0 and later
Information in this document applies to any platform.

Symptoms

Customer is using Tomcat 8.0.53v where as OFSAAI is qualified Apache Tomcat minimum version 8.0.21+ up to version 8.0.38.

Error in Catalina logs:-

22-Aug-2018 12:45:34.497 SEVERE [http-nio-8443-exec-9] org.apache.catalina.core.StandardWrapperValve.invoke Servlet.service() for servlet [jsp] in context with path [/ofsaadev] threw exception [Unable to compile class for JSP:

An error occurred at line: [531] in the generated java file: [/opt/apache-tomcat/apache-tomcat-8.0.53/work/Catalina/localhost/ofsaadev/org/apache/jsp/admin/user_005fgroup_005fauthorization_jsp.java]
The code of method _jspService(HttpServletRequest, HttpServletResponse) is exceeding the 65535 bytes limit

Stacktrace:] with root cause
 org.apache.jasper.JasperException: Unable to compile class for JSP:

An error occurred at line: [531] in the generated java file: [/opt/apache-tomcat/apache-tomcat-8.0.53/work/Catalina/localhost/ofsaadev/org/apache/jsp/admin/user_005fgroup_005fauthorization_jsp.java]
The code of method _jspService(HttpServletRequest, HttpServletResponse) is exceeding the 65535 bytes limit


Changes

 This problem is likely to come when customer uses any version above 8.0.38+

Cause

To view full details, sign in with your My Oracle Support account.

Don't have a My Oracle Support account? Click to get started!


In this Document
Symptoms
Changes
Cause
Solution


My Oracle Support provides customers with access to over a million knowledge articles and a vibrant support community of peers and Oracle experts.