My Oracle Support Banner

"PLS-00302: component 'FROM_REMOTE' must be declared" When Attempting to Manually Upgrade P6 Using Oracle Database Version 12.2 (Doc ID 2545890.1)

Last updated on AUGUST 13, 2021

Applies to:

Primavera P6 Enterprise Project Portfolio Management - Version 18.8 to 18.8.9.0 [Release 18.8]
Primavera P6 Professional Project Management - Version 18.8 to 18.8.9.0 [Release 18.8]
Information in this document applies to any platform.

Symptoms

When attempting to manually upgrade P6 from version 6.2 to 18.8 using Oracle database version 12.2, the following error occurs:

PLS-00302: component 'FROM_REMOTE' must be declared

 

The upgrade fails while executing any of the following scripts under ~\database\scripts\upgrade\$VERSION\:

ORPM_p6.sql
ORPM_p61.sql
ORPM_p62.sql
ORPM_p70sp1.sql
ORPM_p70sp3.sql
ORPM_p70sp5.sql
ORPM_p80.sql
ORPM_p81.sql
ORPM_p81sp3.sql
ORPM_p81sp4.sql
ORPM_p82.sql
ORPM_p82sp1.sql
ORPM_p82sp2.sql
ORPM_p82sp2f10.sql
ORPM_p82sp3.sql
ORPM_p82sp5.sql
ORPM_p83.sql
ORPM_P84.sql

Cause

To view full details, sign in with your My Oracle Support account.

Don't have a My Oracle Support account? Click to get started!


My Oracle Support provides customers with access to over a million knowledge articles and a vibrant support community of peers and Oracle experts.