My Oracle Support Banner

Viewer Study Mode Displays A Default Symbol After Model Build (Doc ID 2554404.1)

Last updated on OCTOBER 10, 2019

Applies to:

Oracle Utilities Network Management System - Version 2.3.0.2.0 to 2.4.0.0.0 [Release 2.3 to 2.4]
Oracle Network Management for Utilities - DMS - Version 2.3.0.2.0 to 2.4.0.0.0 [Release 2.3 to 2.4]
Information in this document applies to any platform.

Symptoms

On : 2.3.0.2.0 version, Web Workspace

Viewer study mode displays a default symbol after model build

After a model build changed a transformer from A-phase to B-phase, the Viewer was showing the wrong symbol for the device when the viewer was in study mode.

The client log had this warning:

2019-06-06 11:18:22,517 [pool-4-thread-1] WARN com.splwg.oms.client.viewer.GuiDevice: getSymbol: could not find symbol for 206.14126285 (20604 1 true)



The issue can be reproduced at will with the following steps:

1. Log into WebWorkspace and start two Viewers
2. On both Viewers, load a 1-phase transformer
3. Set Viewer 2 to study mode; Reset Study to Nominal
4. On Viewer 2, operate (open) the transformer
Viewer1 shows red triangle (closed symbol)
Viewer2 shows abnormal indicator around green triangle (open symbol)

5. Change the phase for the 1-phase in the import file.  Rebuild the map.
Viewer1 shows red triangle (closed symbol)
Viewer2 should now also show the red triangle (closed symbol), since the phas
es changed.

6. On Viewer 2, open and close the transformer
Viewer 2 should not show invalid or missing symbols.

Cause

To view full details, sign in with your My Oracle Support account.

Don't have a My Oracle Support account? Click to get started!


In this Document
Symptoms
Cause
Solution
References


My Oracle Support provides customers with access to over a million knowledge articles and a vibrant support community of peers and Oracle experts.