My Oracle Support Banner

UpgradeStar.sh Failed With Errors On Step 8/86 Part 1/1 "ORA-00406: COMPATIBLE parameter needs to be 12.0.0.0.0 or greater" (Doc ID 2555514.1)

Last updated on JANUARY 22, 2020

Applies to:

Primavera Analytics - Version 18.8 and later
Information in this document applies to any platform.

Symptoms

Problem Description
---------------------------------------------------
Running upgradeStar.sh on newly upgraded database results in the following error:
3. Launched upgradeStar.sh.

Failure at Step 8/86 Part 1/1.

11:25:07.510 [main] INFO ETL.Message - Connecting to database...
11:25:07.614 [main] INFO ETL.Message - Connecting to database...
11:25:07.665 [main] INFO ETL.Progress - Step 8/86 Part 1/1 - [06/04/2019 11:25:07] CreateSynonyms -- Create synonyms (create_synonyms.sql)
11:25:07.665 [main] INFO ETL.Message - === Step 8, Part 1 ====================================================
11:25:07.666 [main] INFO ETL.Message - === Create synonyms (create_synonyms.sql)
11:25:07.735 [Thread-1] INFO ETL.Message - begin
11:25:07.735 [Thread-1] INFO ETL.Message - *
11:25:07.735 [Thread-1] INFO ETL.Message - ERROR at line 1:
11:25:07.735 [Thread-1] INFO ETL.Message - ORA-00406: COMPATIBLE parameter needs to be 12.0.0.0.0 or greater
11:25:07.735 [Thread-1] INFO ETL.Message - ORA-00722: Feature "Editions"
11:25:07.736 [Thread-1] INFO ETL.Message - ORA-06512: at line 25
11:25:07.736 [Thread-1] INFO ETL.Message - ORA-06512: at line 31
11:25:07.752 [main] INFO ETL.Progress - Step 8/86 Part 1/1 - FAILED (150) (0 hours, 0 minutes, 0 seconds, 700 milliseconds)

Cause

To view full details, sign in with your My Oracle Support account.

Don't have a My Oracle Support account? Click to get started!


In this Document
Symptoms
Cause
Solution
References


My Oracle Support provides customers with access to over a million knowledge articles and a vibrant support community of peers and Oracle experts.