My Oracle Support Banner

Inventory Adjustments Interfaced through RIB Fails for the Child Item with the Error :"Item must be at transaction level or above" (Doc ID 2592802.1)

Last updated on OCTOBER 14, 2019

Applies to:

Oracle Retail Merchandising System - Version 16.0.2 and later
Information in this document applies to any platform.

Symptoms

When attempting to interface Inventory Adjustements using Retail Integration Bus(RIB),
the following error occurs:

Steps To Recreate:

1) Identify the item"ITEM111" (ITEM_LEVEL "1" , TRAN_LEVEL "1") attached to  a Store  and its barcode/child item "ITEM222" (ITEM_LEVEL "2" TRAN_LEVEL "1").
2) Invoke Inventory Adjustment Message (RMSSUB_INVADJUST.CONSUME) for the Barcode/Child Item "ITEM222".
3)  Inventory Adjustment Message  with the below error:

Item must be at transaction level or above. Program:NEW_ITEM_LOC_SQL.VALIDATE Item :xxxxxxxxx Item Level :2 Tran Level :1



Changes

 

Cause

To view full details, sign in with your My Oracle Support account.

Don't have a My Oracle Support account? Click to get started!


In this Document
Symptoms
Changes
Cause
Solution
References


My Oracle Support provides customers with access to over a million knowledge articles and a vibrant support community of peers and Oracle experts.