My Oracle Support Banner

OPA Hub Message Log Not Updated After Upgrade To 19A (Doc ID 2626531.1)

Last updated on APRIL 06, 2020

Applies to:

Oracle Policy Automation - Version 12.2.14 and later
Information in this document applies to any platform.

Symptoms

OPA Hub Message Log not getting updated after upgrade to 19A

STEPS:

====

  1. Installed OPA 19A in the Linux OS.
  2. Login into the OPA HUB >> Connection Tab.
  3. Create a new connection to an invalid URL (e.g. "http://yokelhost/MyConnector").
  4. No Logging getting recorded in the Message Tab.


In the WebLogic turn up the Manager Server Logging. Following Errors are seeing the Log file

ERROR:
=====
2019-08-20 17:37:04,828 [STANDBY] ExecuteThread: '4' for queue: 'weblogic.kernel.Default (self-tuning)' ERROR Error processing element DataAdapterError ([Appenders: null]): CLASS_NOT_FOUND
2019-08-20 17:37:05,032 [STANDBY] ExecuteThread: '4' for queue: 'weblogic.kernel.Default (self-tuning)' ERROR Unable to locate appender "RN_LOGGER" for logger config "OPAHubLogger"
2019-08-20 17:37:05,032 [STANDBY] ExecuteThread: '4' for queue: 'weblogic.kernel.Default (self-tuning)' ERROR Unable to locate appender "RN_LOGGER" for logger config "DataAdapterErrorLogger"

 

Changes

 

Cause

To view full details, sign in with your My Oracle Support account.

Don't have a My Oracle Support account? Click to get started!


In this Document
Symptoms
Changes
Cause
Solution
References


My Oracle Support provides customers with access to over a million knowledge articles and a vibrant support community of peers and Oracle experts.