My Oracle Support Banner

Cannot Update Non-sellable Level Two Item Via XItem API (Doc ID 2642971.1)

Last updated on APRIL 16, 2021

Applies to:

Oracle Retail Merchandising System - Version 15.0.1 and later
Information in this document applies to any platform.

Symptoms

Unable to update non-sellable level 2 items via xitem API which was created from UI. Following error occurs.

Steps to reproduce:
-------------------
1) Create a level 2 non-sellable item from the UI.
2) Note that for the child item original_retail will be populated as 0.
3) Send a xitemmod message for the child item(for e.g, to update the description). Note the above error occurs.

Cause

To view full details, sign in with your My Oracle Support account.

Don't have a My Oracle Support account? Click to get started!


In this Document
Symptoms
Cause
Solution
References


My Oracle Support provides customers with access to over a million knowledge articles and a vibrant support community of peers and Oracle experts.