My Oracle Support Banner

Encounter the Error Ora-04009 While Upgrading the Database for Oracle Revenue Management and Billing (Ormb) from Version 2.4.0.0.0 To Version 2.4.0.1.0 (Doc ID 2653924.1)

Last updated on APRIL 03, 2020

Applies to:

Oracle Financial Services Revenue Management and Billing - Version 2.4.0.0.0 and later
Information in this document applies to any platform.

Goal

As part of the upgrade from ORMB 2.4.0.0.0 to 2.8.0.0.0, we are executing steps suggested in the Oracle installation Guide. These include upgrading from ORMB v2.4.0.0.0 to 2.4.0.1.0.
While upgrading the database step for 2.4.0.0 to 2.4.0.1 we are getting a sequence 'CI_PAY_HSTG_SEQ Maxvalue' error.

Steps Followed on the Database:

1) installed Oracle Utilities Application Framework (OUAF) Version 4.2.0.3.0
2) Installed Rollup Pack for OUAF Version 4.2.0.3.0
3) Execute ORMB v2.4.0.1.0\2_Linux86-64bit\RMB\Upgrade\Oracle\Install-Upgrade\CdxDBI.exe

Encounter the following:

ERROR: ORA-04009: MAXVALUE cannot be made to be less than the current value (DBD ERROR: OCIStmtExecute) occurred while executing ALTER SEQUENCE CI_PAY_HSTG_SEQ MAXVALUE 99999
 

Solution

To view full details, sign in with your My Oracle Support account.

Don't have a My Oracle Support account? Click to get started!


In this Document
Goal
Solution
References


My Oracle Support provides customers with access to over a million knowledge articles and a vibrant support community of peers and Oracle experts.