My Oracle Support Banner

Documaker TLS 1.2 Support (Doc ID 2663927.1)

Last updated on APRIL 28, 2020

Applies to:

Oracle Documaker - Version 12.4 and later
Information in this document applies to any platform.

Goal

On : 12.4 version
 
Would like to update the communications to TLS 1.2. Recently made the update, and saw errors within Documaker 12.4 connecting to SQL Server. Currently using the JNDI connection using the microsoft JDBC driver.

It almost seems the java 1.7 version is not supporting TLS 1.2. The error was a NullPointerException:

Transaction Error Report - System timestamp: mon mar 30 12:06:23 2020

DM12041: Error : FAP library error: Transaction:<>, area:
  code1:, code2:
  message:
Stack Trace:

java.lang.NullPointerException>.

DM12041: Error : FAP library error: Transaction:<>, area:<LBYInitializeLoaders()>
  code1:, code2:
  message:>.
DM15066: Error in RunGenData: Unable to LBYInitializeLoaders(). The system is configured to use Library Manager but the library could not be initialized. Verify that the library is specified correctly in the INI file and is accessible.
 
==> Warning count: 0
==> Error count: 3

 
The console had this:

Mar 30, 2020 12:16:54 PM com.microsoft.sqlserver.jdbc.TDSChannel enableSSL
INFO: java.security path: C:\dotnetsvc-applications\DOAM-TEST-AMSDocumaker\rp\jre\lib\security
Security providers: [SUN version 1.7, SunRsaSign version 1.7, SunEC version 1.7, SunJSSE version 1.7, SunJCE version 1.7, SunJGSS version 1.7, SunSASL version 1.7, XMLDSig version 1.0, SunPCSC version 1.7, SunMSCAPI version 1.7]
SSLContext provider info: Sun JSSE provider(PKCS12, SunX509 key/trust factories, SSLv3, TLSv1)
SSLContext provider services:
[SunJSSE: KeyFactory.RSA -> sun.security.rsa.RSAKeyFactory
  aliases: [1.2.840.113549.1.1, OID.1.2.840.113549.1.1]
, SunJSSE: KeyPairGenerator.RSA -> sun.security.rsa.RSAKeyPairGenerator
  aliases: [1.2.840.113549.1.1, OID.1.2.840.113549.1.1]
, SunJSSE: Signature.MD2withRSA -> sun.security.rsa.RSASignature$MD2withRSA
  aliases: [1.2.840.113549.1.1.2, OID.1.2.840.113549.1.1.2]
, SunJSSE: Signature.MD5withRSA -> sun.security.rsa.RSASignature$MD5withRSA
  aliases: [1.2.840.113549.1.1.4, OID.1.2.840.113549.1.1.4]
, SunJSSE: Signature.SHA1withRSA -> sun.security.rsa.RSASignature$SHA1withRSA
  aliases: [1.2.840.113549.1.1.5, OID.1.2.840.113549.1.1.5, 1.3.14.3.2.29, OID.1.3.14.3.2.29]
, SunJSSE: Signature.MD5andSHA1withRSA -> sun.security.ssl.RSASignature
, SunJSSE: KeyManagerFactory.SunX509 -> sun.security.ssl.KeyManagerFactoryImpl$SunX509
, SunJSSE: KeyManagerFactory.NewSunX509 -> sun.security.ssl.KeyManagerFactoryImpl$X509
  aliases: [PKIX]
, SunJSSE: TrustManagerFactory.SunX509 -> sun.security.ssl.TrustManagerFactoryImpl$SimpleFactory
, SunJSSE: TrustManagerFactory.PKIX -> sun.security.ssl.TrustManagerFactoryImpl$PKIXFactory
  aliases: [SunPKIX, X509, X.509]
, SunJSSE: SSLContext.TLSv1 -> sun.security.ssl.SSLContextImpl$TLS10Context
  aliases: [TLS, SSL, SSLv3]
, SunJSSE: SSLContext.TLSv1.1 -> sun.security.ssl.SSLContextImpl$TLS11Context
, SunJSSE: SSLContext.TLSv1.2 -> sun.security.ssl.SSLContextImpl$TLS12Context
, SunJSSE: SSLContext.Default -> sun.security.ssl.SSLContextImpl$DefaultSSLContext
, SunJSSE: KeyStore.PKCS12 -> sun.security.pkcs12.PKCS12KeyStore]
java.ext.dirs: C:\dotnetsvc-applications\DOAM-TEST-AMSDocumaker\rp\jre\lib\ext;C:\WINDOWS\Sun\Java\lib\ex
Error in main(): Unable to RunGenData(). See error file for more messages.

 Is there a workaround?
 

Solution

To view full details, sign in with your My Oracle Support account.

Don't have a My Oracle Support account? Click to get started!


In this Document
Goal
Solution
References


My Oracle Support provides customers with access to over a million knowledge articles and a vibrant support community of peers and Oracle experts.