My Oracle Support Banner

RUP Installation Fails While Running Upgrade_Schema Utility (Doc ID 2722742.1)

Last updated on OCTOBER 26, 2020

Applies to:

Oracle Agile PLM Framework - Version 9.3.6.0 and later
Information in this document applies to any platform.

Symptoms

Getting below error while running the DB schema update scripts Upgrade_Schema.sh/Upgrade_Schema.bat for 9.3.6 RUP
 

Error

Upgrading Schema:
Result:212
BUILD FAILED
Refer /log/oracle_936XX_log for more details


When checking oracle_936XX_log, see information like below:
Your Agile database schema name is - AGILE
Your agile database schema version is 9.3.525.YY
Your agile database data version is 9.3.525.YY.0
PROCEED: This script will upgrade your db from AGILE936xx to AGILE936yy
Your db schema version will be upgraded from 9.3.525.YY to 9.3.525.XX
Your db data version will be upgraded from 9.3.525.YY.0 to 9.3.525.XX.0

YY shows higher number than XX

SP2-0606: Cannot create SPOOL file "exit_wrongVersion.sql"
not spooling currently

1 row updated.

ALTER TABLE REFERENCE_OBJECT ADD CONSTRAINT REF_OBJ_PK PRIMARY KEY (ID)
                                                       *
ERROR at line 1:
ORA-02260: table can have only one primary key



Steps

The issue can be reproduced at will with the following steps:
1. Run Upgrade_Schema.sh/Upgrade_Schema.bat extracted from RUP installer
2. Gets error

Changes

 

Cause

To view full details, sign in with your My Oracle Support account.

Don't have a My Oracle Support account? Click to get started!


In this Document
Symptoms
Changes
Cause
Solution


My Oracle Support provides customers with access to over a million knowledge articles and a vibrant support community of peers and Oracle experts.