My Oracle Support Banner

After Enabling SSO In An On-Premise Unifier Environment, Autovue Stopped Working (Doc ID 2764130.1)

Last updated on APRIL 09, 2021

Applies to:

Primavera Unifier - Version 19.12.4.0 and later
Information in this document applies to any platform.

Symptoms

In an on-premise environment AutoVue is no longer working after Generic SSO authentication was configured. It was working prior to the changes, but it should be noted that SSO is working fine. There are two other Unifier environments (connected to different AutoVue instances) that are working fine from the same browser and or user computer, however Generic SSO is not configured in those other Unifier environments. When trying to open a BP record attachment (basic PDF file) via AutoVue, nothing happens. No JNLP file is downloaded, nothing seems to happen in the browser.


EXPECTED BEHAVIOR
-----------------------
When "Open with AutoVue" is selected, a JNLP file should be downloaded, user can launch with Java (TM) Web Launcher to initiate Java and then AutoVue as per the usual steps.


STEPS
-----------------------
The issue can be reproduced at will with the following steps:

  1. Log into the Unifier Environment.
  2. Navigate to the Project/Shell where the issue has been observed > Upper BP node > Specific BP Log > Open a BP record > View "Attachments" tab > Three is one attachment > Click the gear icon next to it > Select "Open in AutoVue"
  3. Nothing obvious happens, no Java, no JNLP download, etc.

Cause

To view full details, sign in with your My Oracle Support account.

Don't have a My Oracle Support account? Click to get started!


In this Document
Symptoms
Cause
Solution
References


My Oracle Support provides customers with access to over a million knowledge articles and a vibrant support community of peers and Oracle experts.