My Oracle Support Banner

Groovy Compilation Errors after upgrading to 21A (Doc ID 2770044.1)

Last updated on APRIL 19, 2021

Applies to:

Oracle Utilities Customer Care and Billing - Version 2.8.0.0.0 and later
Oracle Utilities Framework - Version 4.4.0.2.0 and later
Oracle Utilities Customer Cloud Service - Version 21A and later
Oracle Utilities Meter Solution Cloud Service - Version 21A and later
Oracle Utilities Work and Asset Cloud Service - Version 21A and later
Information in this document applies to any platform.

Goal

 In 21A, Groovy was upgraded from version 2.4.12 to version 3.0.7. Groovy introduced a change in behavior in this newer version. It is unknown whether this change in behavior is intentional or a defect.

Here is one example error:

 

Solution

To view full details, sign in with your My Oracle Support account.

Don't have a My Oracle Support account? Click to get started!


In this Document
Goal
Solution

My Oracle Support provides customers with access to over a million knowledge articles and a vibrant support community of peers and Oracle experts.