My Oracle Support Banner

Dependency On Database Upgrade From 12c To 19c (Doc ID 2829351.1)

Last updated on DECEMBER 23, 2021

Applies to:

Oracle Communications Billing and Revenue Management - Version 12.0.0.2.0 and later
Information in this document applies to any platform.

Goal

Having an environment with Billing and revenue management (BRM) (12.0.0.2.0), Pricing Design Center (PDC) (12.0.0.2.0) and Elastic Charging Engine (ECE) (12.0.0.2.0) on version 12 Patch Set (PS) 2. Currently all these apps (BRM,PDC and ECE) are using 12c version Database (DB).
Planning to upgrade database version from 12c to 19c.So need confirmation on below points:


BRM:
1) Any script to be run to change the configuration or any configuration need to be made manually to enable BRM to connect to 19c DB.
2) Does existing .so files support 19c database or any kind of installation need to be made to get new .so that supports 19c DB.
  
PDC and BRM integration pack:
1) Is any config changes required on PDC?
2) Is any config changes required on BRM integration pack (syncPDC , RRE)?

ECE:
1) Is any config changes required from ECE side?
 

Solution

To view full details, sign in with your My Oracle Support account.

Don't have a My Oracle Support account? Click to get started!


In this Document
Goal
Solution


My Oracle Support provides customers with access to over a million knowledge articles and a vibrant support community of peers and Oracle experts.