My Oracle Support Banner

UnsupportedClassVersionError when Starting Adapter LTMH Server after Upgrade to Oracle 19c with new ojdbc version (Doc ID 2879586.1)

Last updated on JUNE 27, 2022

Applies to:

Oracle Utilities Market Settlements Management - Version 1.6.1.23 and later
Oracle Utilities Rate Management - Version 1.6.1.23 and later
Oracle Utilities Billing Component - Version 1.6.1.23 and later
Oracle Utilities Energy Information Platform - Version 1.6.1.23 and later
Oracle Utilities Meter Data Management - Version 1.6.1.23 and later
Information in this document applies to any platform.

Symptoms

 With update to Oracle client 19c, ojdbc10.jar was installed on our server but the following message occurs when starting the LTMH Server for the adapter:

java.lang.UnsupportedClassVersionError: oracle/jdbc/OracleDriver has been compiled by a more recent version of the Java Runtime (class file version 54.0), this version of the Java Runtime only recognizes class file versions up to 52.0

Changes

 

Cause

To view full details, sign in with your My Oracle Support account.

Don't have a My Oracle Support account? Click to get started!


In this Document
Symptoms
Changes
Cause
Solution


My Oracle Support provides customers with access to over a million knowledge articles and a vibrant support community of peers and Oracle experts.