My Oracle Support Banner

TMS 5.2.x Dictionary Upgrade : ' Verbatim Terms must not map to a non-approved Dictionary Term ' and ' Cardinality violation - Too many relations' (Doc ID 2958746.1)

Last updated on JULY 03, 2023

Applies to:

Oracle Thesaurus Management System - Version 5.2.3 and later
Information in this document applies to any platform.

Symptoms

The following errors from the predict tables ( tms_predict_contents and tms_predict_relations) are received during Dictionary Upgrade:

Example errors:

Verbatim Terms must not map to a non-approved Dictionary Term
or
Verbatim Terms must not map to a non-approved Dictionary Term ( <term_id>)

Info: The error message indicates that there is a VTA that is mapped to it

Leading to error : Cardinality violation - Too many relations.

For the error 'Cardinality violation - Too many relations' this was seen for the term which had to be updated ( DML= Update ).

 

Supposing (example) the following TERMS are reported with this issue :
==================================================
MYOCARDIAL STRAIN
ASPIRATION BRONCHIAL
PRURITIS
CATHETER THROMBOSIS

Changes

Dictionary Upgrade.
In this example similar errors had been received during Meddra Dictionary upgrade.

Cause

To view full details, sign in with your My Oracle Support account.

Don't have a My Oracle Support account? Click to get started!


In this Document
Symptoms
Changes
Cause
Solution


My Oracle Support provides customers with access to over a million knowledge articles and a vibrant support community of peers and Oracle experts.