My Oracle Support Banner

Snapshots Giving Wrong Results When Accessed Through Business Area (Doc ID 2971055.1)

Last updated on SEPTEMBER 01, 2023

Applies to:

Oracle Life Sciences Data Hub - Version 3.1.1.5 and later
Information in this document applies to any platform.

Symptoms

Snapshots are giving wrong results when accessed through a Business Area.

Steps to reproduce:

1. Create table1 and table2

2. Load data into table1

3. Don't load data for table2

4. Apply snapshot label -> snap_label1 to both tables
    Snapshot label -> snap_label1 is applied to table1 since it has data
    Snapshot label -> snap_label1 is not applied to table2 as it doesn't have data

5. Load data into table1 again

6. Load data into table2

7. Apply snapshot label -> snap_label2 to both tables
    Snapshot label -> snap_label2 is applied to table1 since it has data
    Snapshot label -> snap_label2 is applied to table2 as it has data this time

8. Create a new table3

9. Load data into table1 again

10. Load data to table2 again

11. Load data to table3

12. Apply snapshot label -> snap_label3 to all the tables
     Snapshot label -> snap_label3 is applied to table1 since it has data
     Snapshot label -> snap_label3 is applied to table2 as it has data
     Snapshot label -> snap_label3 is applied to table3 as it has data

13. Initialize BA with snap_label1
     select * from <BA schema name>.table1; --> Gives correct snap_label1 data
     select * from <BA schema name>.table2; --> Gives snap_label3 data (INCORRECT)
     select * from <BA schema name>.table3; --> Gives snap_label3 data (INCORRECT)

14. Initialize BA with snap_label2
     select * from <BA schema name>.table1; --> Gives correct snap_label2 data
     select * from <BA schema name>.table2; --> Gives correct snap_label2 data
     select * from <BA schema name>.table3; --> Gives snap_label3 data (INCORRECT)

15. Initialize BA with snap_label3
     select * from <BA schema name>.table1; --> Gives correct snap_label3 data
     select * from <BA schema name>.table2; --> Gives correct snap_label3 data
     select * from <BA schema name>.table1; --> Gives correct snap_label3 data

This is only happening when accessing the snapsots through the Business Area. All results are fine when accessed through the UI.

Cause

To view full details, sign in with your My Oracle Support account.

Don't have a My Oracle Support account? Click to get started!


In this Document
Symptoms
Cause
Solution
References


My Oracle Support provides customers with access to over a million knowledge articles and a vibrant support community of peers and Oracle experts.