My Oracle Support Banner

'Upgrade Required' Toolbar Function No Longer Working (Doc ID 2984792.1)

Last updated on NOVEMBER 02, 2023

Applies to:

Oracle Life Sciences Data Management Workbench - Version 3.3 and later
Information in this document applies to any platform.

Goal

In the latest version of DMW 3.3, the 'Upgrade required' reporting in the Transformation tab no longer works as expected.

If the user makes changes to a Clinical Data Model Table or to a Transformation source model, the expectation (and previous behavior) is the Transformation will display 'Upgrade Required: Yes'. This no longer occurs. Instead, the user must manually execute 'Upgrade Map'. The user must remember to do this each time underlying table objects are modified.

If a column is added as the 'last' column in an existing table, this issue is not observable but still the 'Upgrade Map' must be run manually in order for the transformation to install.

If adding a column and then reordering, i.e., moving the new column up the list of columns, any column mapping in the columns moving down order (order = n-1) will be displayed as lost in the Transformation tab > Target Columns. No 'Upgrade Required: Yes' is displayed on the Transformation tab for the data model. Once the user executes the 'Upgrade Map' functionality, all of the 'lost' column mappings are once again displayed as complete.

The same behavior is observed if changing a table column. The expectation after making any changes to tables in a Clinical Data Model is the 'Upgrade Required: Yes' flag is displayed in the Transformation tab.
 

Solution

To view full details, sign in with your My Oracle Support account.

Don't have a My Oracle Support account? Click to get started!


In this Document
Goal
Solution
References


My Oracle Support provides customers with access to over a million knowledge articles and a vibrant support community of peers and Oracle experts.